Page 19 of 19

Crashes on 1.0.8 Mac OS X in Green Goblin Corridoor

PostPosted: Fri Nov 27, 2020 10:56 pm
by karianna
I think it's just about whenever the King does anything the game crashes :-(. This is the battle in the corridor with the Giant Scorpian, King with Max'd spells and psionic beetle. Can't progress the game past this.

Re: Bug reports

PostPosted: Sat Nov 28, 2020 2:26 pm
by BlueSalamander
Feats are showing up as optional when they are already taken. The ones I've noticed have all been monk. Improved arrow catching, among others.
Thank you! I will check this out and fix it.

I think it's just about whenever the King does anything the game crashes :-(. This is the battle in the corridor with the Giant Scorpian, King with Max'd spells and psionic beetle. Can't progress the game past this.
Thank you. I've just tested this battle with version 1.08. I got beaten thoroughly, but there wasn't any crash. It might have something to do with your saved game. Please could you send it to me at and I will investigate? Cheers :)

Re: Bug reports

PostPosted: Sat Mar 06, 2021 10:40 pm
by BlueSalamander
Whew! Finally got around to reading pages 1-14 of this thread, which is important because while many of the mentioned bugs have been fixed, some still have not.

the wisdom-based monk-dodge-bonus isn't influenced if your monk wears an item with a wisdom enhancement or has an 'enhance ability' spell on him
I'll have to check it out, but looking at the code, it seems to be taking the wisdom value after the enhancements.

The red wizard 50% fire energy resistance after transforming does not seem to work.
OK, have to check it out.

Twice I've seen a gust of wind spell go through fog squares and fail to dispel the fog, without any indication of anything in the combat log.
That's probably fixed by now, though acid fog and solid fog cannot be dispelled by gust of wind.

If I make the archdemon that joins for the castle area my party leader, I cannot undo it. It says there is not enough space to swap the formation, regardless of how I shift things around. The demon takes 4 spaces. Even if I create a gap of 6 spaces to swap into, it says there is not enough space to swap.
Thanks, I will look into this.

Prismatic wall gives a "100%" indication on flying enemies, when it can't actually affect flying enemies (sometimes I space out and just look at the percent). Edit: Meanwhile for "evil cultist" the same spell does have an effect but it is marked as "-" indicating no possible effect when targeting.
Thank you, I will check it out.

Some hot keys are overloaded. For example, if I am in the spells tab and hit "I" to go to inventory, instead it focuses on the "Ice Lance" spell. I think I've also noticed sometimes when I'm in the inventory and I hit "V" to go to the char sheet, it takes a few tries to work, but I haven't determined the cause of that one yet.
About this, it depends on where the mouse cursor is. Please mouse away from all the controls to gain access to the main shortcut keys.

Protection from Evil is supposed to protect against "mind control". I assume this includes "Dominated"? However, I had a character with Greater Protection from Evil get dominated by an Evil enemy.
I think I have found the reason for this. The 'Dominate' psionic power lacks the 'Mind Control' descriptor. I will correct that in version 1.12. All the other control and dominate spells already have the Mind Control descriptor.

Krillion - the latest update says something about talking to Krillion, his quest and artifact rewards. Assuming this refers to the grey goblin walking by the entrance, I am not able to talk or interact with him.
You talk to him by interacting with the portcullis. I think I might add a dialogue screen to point this out when you reach this area for the first time.

The Evil Cultist Archers readied actions to shoot if one of my people cast a spell. One of my people cast a spell, and they took a full attack worth of shots at the spellcaster. Only problem is, you can only ready a standard action, not a full-round action, which means they should only get 1 shot against the spellcaster.
Not a bug though; they are Fighters with the Wade In feat, which allows them to do a Full Attack with a standard action.

Rapid Shot: not getting all the shots that I should. Every now and then I notice the shot counter will increment to the next-to-last shot and then I don't get the last one. So if I should normally get 5 shots with rapid shot, it gets to 4/5 and then ends my turn. Seems to only happen on a miss but I may be wrong.
Thanks, is this still happening in version 1.11?

Not sure if it is just how the combat log is worded, but I tripped somebody who was balancing, succeeded on the touch attack, then it said "Balancing target: automatic success. Trip fails." Doesn't make sense.
Is this still happening? Thank you.

After the big main fight in the castle with the red dragon, I headed north. I saw a door which, when I opened it, lead to a small room with some generic enemies and a commander. Upon vanquishing him, I explored the room. There is a chest in the right side of the room. You cannot select it (it says "obstructed" in the mouseover). Not sure that was intended.
Thanks. Actually, that chest is empty. But I will put some gold into it and attach a script to it so that the player can check it out.

The arrow keys don't seem to allow me to scroll the screen left when I am in a battle at the top left corner of the map and the combat menu is being displayed... it works to use the mouse but not the arrows. The combat menu can obscure some of the combatants if not scrolled.
Yup. Just checked. I will fix it.

If a knockback arrow damage makes my char unconscious due to the initial damage from the hit prior to the knockback, it still plays the knockback audio.
I think this was fixed at some point.

I don't think the chessmaster is giving out the correct gold prize based on the number of rounds, according to what the dialog says before the battle. I did it with a depleted party (low health and zero spells left) just to see if I could get it done and not have to come back later... so it took me 3 rounds (would have been a lot more if not for the Executioner), but I got the "1 round" reward. Not that I'm complaining for getting extra
Mm, I will have to check it out.

no answer that I am able to type in satisfies the riddler; either using the /2 or /3 divisor.
I think that one has been fixed, it's the issue with answers containing a slash.

The psychic vampire was healed by my cure moderate wounds.
I think this was fixed at some point.

In the spec bar you can set what to do when your character got an AoO but right now the only option available is 'attack'. Is this a bug? Cause I really wanted to set it on 'trip' with my trip specialist...
It depends; do you have the feat Greater Trip? You need that feat in order to set the AOO action as Trip.

I cast Fire Storm. Supposed to create an area 15'x40'. It only allowed me to target an individual, and he was the only one affected by the spell even though there were six enemies clustered around him.
Thanks, I will check it out.

Scadulgon immediately initiates the dialogue again, when I tell him I want to come back later. I therefore could not go back and prepare again etc.
I'll check it out, I can't remember if I've fixed it already or not. :)

At the Keyboard puzzle, I used the scroll of Elegy as was proper. I pressed the proper notes (A G A G F E D D D b) but nothing happened. I tried all combinations of B, b and Db, to no avail. According to the hint, I was correct.
Is this issue still happening? Thanks.

The Emperor Eye seemed to be worth more XP to the higher level characters than the lower level ones, which is the opposite of how it normally works. His minions gave out higher XP to the lower level characters as normal.
Thanks, I'll check it out.

problem with Dragontooth +1 and full inventory
Thanks, I will check it out.

Open Bag, Drop an item A on the bag in the backpack. The bag and that item A swap places in backpack, Drop item A in bag slot. Game crashes
Will check it out, not sure if it was fixed already.

Huge fight with Queen Sattram, the Spider. I managed to knock her down to 1 hp. On her turn, she cast False Life, then she cast it again (she is accelerated). They stacked with each other! She was back up to 60hp! That's a big no-no. Temporary hit points, especially from the same source, overwrite. You get the higher of the two; they never stack.
Not a bug, though; that's just how the spell works in KotC 1 and KotC 2. Temporary HP here only means that you can exceed the character's maximum HP.

when I was in the weapons and armor menu GUI, and I'd select an item, then select to place it on the map, when it went to the map screen it would place a different item
Not sure what's going on here, I couldn't reproduce it.

The spell targeting highlights aren't always accurate. I've hit my own party with spells that weren't shown as being at risk. I think it is a problem with when there is uneven terrain (the red goblin king fight has that channel running down the middle of the main hallway that is lower than the rest of the area, it seems to break the spell targeting graphics). Also around corners seems to be a problem too.
Right, there is a major reason for inaccurate targeting highlights, it's that the highlights process all Spread spells (like Fireball) as if they were Burst spells. So a spread spell will not show you the targets who are behind corners. The reason for processing as a Burst is that spreads are kinda hard for the computer to calculate and they can produce a visible slowdown if highlights are calculated as a Spread. I might add an option to calculate highlights for Spreads as Spreads and not Bursts, but the default will be Bursts, as the smooth running of the game is usually more important I think.

As for problems when characters are in the channel where you fight the goblin king, I just did some tests but did not find any issues there; spells like fireball correctly highlighted targets who are in the channel, or out of it, depending on whether you're targeting the spell at a square within the channel or out of it.

Crafted an Adamantine Robe (not sure why--didn't give any DR or other bonuses). Enchanted it with a +4 enhancement bonus. The icon disappeared. It took up an inventory slot but no picture.
Thank you, I will check it out.

Enemies summoned a large Air Elemental. He immediately flew into a Cold Energy Wall that the enemies had already placed. He took no damage. No save, no nothing. I checked his stats and there did not seem to be any effect that would render him immune to the spell.
Normal behaviour, Air Elementals are flying creatures.

Hit a Medusian Slime with a wounding weapon. It was immune to the wounding effect. Slimes (including this particular one) should not be immune to wounding--they have a con score and are technically alive.
Okay, but if you check out the Ooze traits in the SRD 3.5, you'll see that they are immune to poison. Wounding in KotC 2 is an enchantment that works similarly to poison. Poison and ability damage are considered to be the same thing.

Shillelagh and magic weapon (psionic) don't allow weapons to pass through at least animated portcullis and gargoyle DR
Thank you, I will check it out.

Excuse the spelling on the names at the moment. But the Lich Xalpinar? And the Vampire lord Drakannon? Are healed by positive energy? The lich receives healing from negative energy as well from spamming mass harm? Is this a bug or supposed to be? Shouldn’t at least one hurt him probably positive energy since he is undead.
Yup, I think I've fixed that at some point.

A character performed a Whirlwind Attack. One of the enemies was killed by the attack. Cleave was not triggered.
Normal behaviour for the game.

Huge Scorpion is standing astraddle a long 5' wide sewer trench. When I missed him in combat with my bow, I checked the combat output and it said that the scorpion had the condition "swimming" and, as a result, received a +8 untyped bonus to AC. This seems way off.
I know it seems bizarre but that's just how the game works. The +8 bonus to AC versus ranged attacks (only) is per design, please see the in-game entry about environmental effects. If a large monster has some squares in the water and some squares out of the water, it's still considered by the game to be swimming. Should I require monsters to be having more than half of their squares in the water in order to receive the Swimming condition?

In the monk character screen under the feats tab, the help area for 'deflect arrows' is not displaying properly, and if you right click on it you get an empty help page.
Thanks, I will check it out.

In the weapon enchantment help, the greater splash enchantments don't seem to have any help page linked to them.
True. Just checked. I will fix it in version 1.12.

Champion's Divine Armour doesn't work, still getting penalties to speed. At least from Golden Cuirass.
Thanks, I will check it out, can't remember if I've already fixed it.

Warlocks gain extra pp from intelligence instead of charisma. Help says it should be cha
Will check it out, thank you.

If you pay the bird guy to take you into the arena and don't have enough gold, it shows you with negative gold and then it doesn't trigger the dialog when you enter the arena, they just start fighting and ignore you.
EDIT: While I can reproduce the negative gold, I could not reproduce the fight starting without the dialog, so not sure anymore if that was real or I spaced out due to being tired, but the negative gold is definitely a bug.
If your warrior jumps you across the arena, the fight doesn't trigger at all and everybody just sits there.
Thanks, I will check it out.

I've noticed that sometimes the game launches in 32-bit mode and sometimes in 64-bit.
How do you know if it's 32 or 64? What difference do you see?

My Mantis Rogue managed to sneak around him and set up flanking. At some point the Efreeti successfully disarmed the Mantis. When I went to attack him, I got the message "Can't Attack this target in Melee Combat (Character is disarmed)". Not only does my mantis have four weapons equipped, meaning that the Efreeti could only have disarmed one of those weapons with a single disarm action, but the mantis has natural claw attacks! Disarming him would certainly lower his DPS, but he should still be able to take unarmed claw attacks (including his sneak attack thanks to flanking, of course!).
You are correct, but that's not how the game works. To keep things simple, disarmed characters can't attack until they rearm.

if I level up a wizard and get 2 arcane spell selections, the next character I level up will show "2" under arcane spell selections even if they are not an arcane caster. Need to reset those after each level up.
Probably already fixed, but I will check it out just in case.

Just wondering if you are able to test on Windows 7? Is Windows 7 officially supported?
I test and develop on Windows 10, but it should works exactly the same on Windows 7.

Fight with the Giant Centipedes: Every hit is an automatic dex damage (presumably due to poison). However, where's the fort save?
Normal behaviour, monsters in KotC 2 don't follow everything from the SRD.

when looking at the Golden Cuirass that I received, it says "Weapon Attribute Masterwork Quality" and "Weapon Enchantment +1 Enhancement". Both should be Armor, not Weapon.
Good point. I'll see if I can change that text.

Still not allowed to make Arcane skill checks with a Warlock or Rogue even though both cast Arcane spells.
Normal behaviour for classes that don't have the Arcana skill. I will consider an option to give Arcana / Warrior / Religion to more classes.

if you go to the character selection / character creation screen and select load game and load a previous save, you'll have your old party with all of their levels and items included at the beginning of a new game. Items can be duplicated this way. I can save the game when I start and redo this five times and then have six of the kickstarter item instead of one.
Thank you, I will check it out.

There's a bug that affects the Cell Divison power. No matter what feats I take, I can only use it on my psychic healer or psion. The improved versions of the ability that allow use on others at touch, and then at Medium Range don't work.
Not sure if I've already fixed that one, so will check it out.

You can save with CTRL-S in between certain scripted dialog scenes that set up for a battle, and then the battle is messed up where a bunch of the enemies are not recognized and don't participate. It would be nice to be able to save during those to save time repeating them when we are trying battles a lot (that we are struggling with). Maybe the game could create a proper autosave in those situations, so we don't have to go through the dialog portion over and over and we can jump directly into battle?
Will check it out, thanks.

I went back into Character Creation. I sat at the character creation screen and alt-tabbed away. Left my computer for a few hours. When I came back I noticed that nothing that I clicked on was responding. I could press <esc> to back out of the creation screen but no mouse clicks. I eventually had to <esc> back to the main menu but the mouse still would not work, so I had to force close.
I will check it out, thank you.

When I am scrolling in the help screen and my mouse strays to the side a bit and happens to touch a link, it navigates to the link. It should only navigate to the link if I click mouse-down while already on the link, if the mouse is already pressed and/or being used for scrolling when it crosses the link area, it should not navigate. It took me a while to figure out why the help was jumping around when I wasn't commanding it to
Not sure if I've already fixed it, will check it out.

I created a party including a female cloudpounder? (whatever has +4 dex) gladiator and the option to use a half-giant to pick up the portcullis in the starting room was unavailable.
Most likely already fixed but I'll check it out, thanks.

CTD: After interacting with the portcullis in the first room I selected "Let the whole party deal with it.". I only have a single character in my party.
Most likely already fixed but I'll check it out, thanks.

Searching the cobweb in the first room does not add a d20 to your check. It instead takes your flat intelligence score (which would require a character with 22INT from level 1, if somehow intended)
Normal behaviour, please see how the Search score is calculated.

Thank you everyone for contributing to this thread! Best regards :)

Re: Bug reports

PostPosted: Sun Mar 21, 2021 6:16 pm
by Sangarunya
In the Magic Weapons section in the Help Files, besides the Greater Splash entries, there are a few more without link:
Giant Sized

Re: Bug reports

PostPosted: Tue Mar 30, 2021 7:00 pm
by Sangarunya
I've been reading the Wizard Spell list in the Help Files and I found several erroneous links (version 1.11):

- Fireball (Wizard 3) -> Grease link not working
- Solid Fog (Wizard 4) -> Fog Cloud link not working
- Globe of Invulnerability (Wizard 4) -> Grease link not working
- Greater Protection from Alignment (Wizard 5) -> Aligned link to empty page
- Baleful Polymorph (Wizard 5) -> Polymorphed link to empty page
- Acid Fog (Wizard 6) -> Fog Cloud link not working
- Contingent Break Enchantment(Wizard 6) -> Feebleminded link to empty page
- Mass Greater Protection from Alignment (Wizard 6) -> Aligned link to empty page
- Transformation (Wizard 7) -> Transformed link to empty page
- Time Control (Wizard 7) -> Full Round Actions link not working
- Mind Blank (Wizard 8) -> Confusion and Hold Person don't show as link and True Seeing doesn't work
- Mass Transformation (Wizard 9) -> Transformed link to empty page
- Contingent Greater Break Enchantment (Wizard 9) -> Feebleminded to empty page
- Mass Mind Blank (Wizard - 9) -> Confusion link not working; Hold Person does not show as a link

Re: Bug reports

PostPosted: Tue Mar 30, 2021 8:00 pm
by Sangarunya
More bad links; this time from the Cleric Spells section:

- Protection from Alignment (Cleric 1) -> Aligned Bonus link does not work
- Silence (Cleric 2) -> Sonic Burst link doesn't work
- Mass Protection from Alignment (Cleric 3) -> Aligned Bonus link does not work
- Insect Plague (Cleric 5) -> Plagued link to empty page
- Greater Protection from Alignment (Cleric 5) -> Aligned link to empty page
- Mass Greater Protection from Alignment (Cleric 6) -> Aligned link doesn't work
- Contingent Break Enchantment (Cleric 6) -> Feebleminded link to empty page
- Contingent Breaker Great Enchantment (Cleric 9) -> Feebleminded link to empty page
- Mass Righteous Magic (Cleric 9) -> Second Righteous Might link doesn't work

Re: Bug reports

PostPosted: Tue Mar 30, 2021 8:30 pm
by Sangarunya
The next bunch:

- Ice Lance (Druid 4) -> Attack Roll link misses the letter 'a'
- Mass Greater Protection from Alignment (Paladin 3) -> Aligned link to empty page
- Zone of Silence (Bard) -> Sonic Burst link does not work
- Expansion (Psychic Warrior 1) -> Expansion link to empty page
- Mind Blank (Physic Warrior 6) -> Confusion and True Seeing links do not work
- Psychic Chirurgery (Psionicist 8) -> Feebleminded link to empty page
- Mass Mind Blank (Psionicist 8) -> Confusion and True Seeing links don't work and Hold Person without link
- Mind Blank (Psionicist 7) -> Same Mass Mind Blank

Re: Bug reports

PostPosted: Thu Apr 08, 2021 9:14 pm
by Peter_Edge
Since 1.12, has anyone else managed to start a new campaign and get banished after defeating the cultists? I beat them, and Yanos remains resolutely unhostile, but untalkative. I have tried both options of entering the room open to me [Bard and usual], and three different interruptions [Bard, Bishop, and one of the dialogues] ...

Re: Bug reports

PostPosted: Fri Apr 09, 2021 2:12 pm
by Peter_Edge
Peter_Edge wrote:Since 1.12, has anyone else managed to start a new campaign and get banished after defeating the cultists? I beat them, and Yanos remains resolutely unhostile, but untalkative. I have tried both options of entering the room open to me [Bard and usual], and three different interruptions [Bard, Bishop, and one of the dialogues] ...

I eventually got around this by adding the right script to the map, which got me into the oubliette. All well until I won the Goblin Arena fight, when pretty much the same happened. Surviving grey goblins stood along not talking to me, gate keeper would not let me into the goblin camp, and the stairs down from the arena to the camp did not appear.